Ubuntu 22.04 STIG V1R1

View as one page
STIG ID CCI Title
UBTU-22-211010 CCI-001233 Ubuntu 22.04 LTS must deploy an Endpoint Security Solution.
UBTU-22-211015 CCI-000366 Ubuntu 22.04 LTS must disable the x86 Ctrl-Alt-Delete key sequence.
UBTU-22-212010 CCI-000213 Ubuntu 22.04 LTS, when booted, must require authentication upon booting into single-user and maintenance modes.
UBTU-22-212015 CCI-001464 Ubuntu 22.04 LTS must initiate session audits at system startup.
UBTU-22-213010 CCI-001090 Ubuntu 22.04 LTS must restrict access to the kernel message buffer.
UBTU-22-213015 CCI-001190 Ubuntu 22.04 LTS must disable kernel core dumps so that it can fail to a secure state if system initialization fails, shutdown fails or aborts fail.
UBTU-22-213020 CCI-002824 Ubuntu 22.04 LTS must implement address space layout randomization to protect its memory from unauthorized code execution.
UBTU-22-213025 CCI-002824 Ubuntu 22.04 LTS must implement nonexecutable data to protect its memory from unauthorized code execution.
UBTU-22-214010 CCI-001749 Ubuntu 22.04 LTS must be configured so that the Advance Package Tool (APT) prevents the installation of patches, service packs, device drivers, or operating system components without verification they have been digitally signed using a certificate that is recognized and approved by the organization.
UBTU-22-214015 CCI-002617 Ubuntu 22.04 LTS must be configured so that the Advance Package Tool (APT) removes all software components after updated versions have been installed.
UBTU-22-215010 CCI-000366 Ubuntu 22.04 LTS must have the "libpam-pwquality" package installed.
UBTU-22-215015 CCI-000366 Ubuntu 22.04 LTS must have the "chrony" package installed.
UBTU-22-215020 CCI-000366 Ubuntu 22.04 LTS must not have the "systemd-timesyncd" package installed.
UBTU-22-215025 CCI-000366 Ubuntu 22.04 LTS must not have the "ntp" package installed.
UBTU-22-215030 CCI-000381 Ubuntu 22.04 LTS must not have the "rsh-server" package installed.
UBTU-22-215035 CCI-000197 Ubuntu 22.04 LTS must not have the "telnet" package installed.
UBTU-22-231010 CCI-001199 Ubuntu 22.04 LTS must implement cryptographic mechanisms to prevent unauthorized disclosure and modification of all information that requires protection at rest.
UBTU-22-232010 CCI-001495 Ubuntu 22.04 LTS must have directories that contain system commands set to a mode of "755" or less permissive.
UBTU-22-232015 CCI-001499 Ubuntu 22.04 LTS must have system commands set to a mode of "755" or less permissive.
UBTU-22-232020 CCI-001499 Ubuntu 22.04 LTS library files must have mode "755" or less permissive.
UBTU-22-232025 CCI-001314 Ubuntu 22.04 LTS must configure the "/var/log" directory to have mode "755" or less permissive.
UBTU-22-232026 CCI-001312 Ubuntu 22.04 LTS must generate error messages that provide information necessary for corrective actions without revealing information that could be exploited by adversaries.
UBTU-22-232027 CCI-001312 Ubuntu 22.04 LTS must generate system journal entries without revealing information that could be exploited by adversaries.
UBTU-22-232030 CCI-001314 Ubuntu 22.04 LTS must configure "/var/log/syslog" file with mode "640" or less permissive.
UBTU-22-232035 CCI-001493 Ubuntu 22.04 LTS must configure audit tools with a mode of "755" or less permissive.
UBTU-22-232040 CCI-001495 Ubuntu 22.04 LTS must have directories that contain system commands owned by "root".
UBTU-22-232045 CCI-001495 Ubuntu 22.04 LTS must have directories that contain system commands group-owned by "root".
UBTU-22-232050 CCI-001499 Ubuntu 22.04 LTS must have system commands owned by "root" or a system account.
UBTU-22-232055 CCI-001499 Ubuntu 22.04 LTS must have system commands group-owned by "root" or a system account.
UBTU-22-232060 CCI-001499 Ubuntu 22.04 LTS library directories must be owned by "root".
UBTU-22-232065 CCI-001499 Ubuntu 22.04 LTS library directories must be group-owned by "root".
UBTU-22-232070 CCI-001499 Ubuntu 22.04 LTS library files must be owned by "root".
UBTU-22-232075 CCI-001499 Ubuntu 22.04 LTS library files must be group-owned by "root".
UBTU-22-232080 CCI-001314 Ubuntu 22.04 LTS must configure the directories used by the system journal to be owned by "root".
UBTU-22-232085 CCI-001314 Ubuntu 22.04 LTS must configure the directories used by the system journal to be group-owned by "systemd-journal".
UBTU-22-232090 CCI-001314 Ubuntu 22.04 LTS must configure the files used by the system journal to be owned by "root".
UBTU-22-232095 CCI-001314 Ubuntu 22.04 LTS must configure the files used by the system journal to be group-owned by "systemd-journal".
UBTU-22-232100 CCI-001314 Ubuntu 22.04 LTS must be configured so that the "journalctl" command is owned by "root".
UBTU-22-232105 CCI-001314 Ubuntu 22.04 LTS must be configured so that the "journalctl" command is group-owned by "root".
UBTU-22-232110 CCI-001493 Ubuntu 22.04 LTS must configure audit tools to be owned by "root".
UBTU-22-232120 CCI-001314 Ubuntu 22.04 LTS must configure the "/var/log" directory to be owned by "root".
UBTU-22-232125 CCI-001314 Ubuntu 22.04 LTS must configure the "/var/log" directory to be group-owned by "syslog".
UBTU-22-232130 CCI-001314 Ubuntu 22.04 LTS must configure "/var/log/syslog" file to be owned by "syslog".
UBTU-22-232135 CCI-001314 Ubuntu 22.04 LTS must configure the "/var/log/syslog" file to be group-owned by "adm".
UBTU-22-232140 CCI-001312 Ubuntu 22.04 LTS must be configured so that the "journalctl" command is not accessible by unauthorized users.
UBTU-22-232145 CCI-001090 Ubuntu 22.04 LTS must set a sticky bit on all public directories to prevent unauthorized and unintended information transferred via shared system resources.
UBTU-22-251010 CCI-002314 Ubuntu 22.04 LTS must have an application firewall installed in order to control remote access methods.
UBTU-22-251015 CCI-002314 Ubuntu 22.04 LTS must enable and run the Uncomplicated Firewall (ufw).
UBTU-22-251020 CCI-000366 Ubuntu 22.04 LTS must have an application firewall enabled.
UBTU-22-251025 CCI-002385 Ubuntu 22.04 LTS must configure the Uncomplicated Firewall (ufw) to rate-limit impacted network interfaces.
UBTU-22-251030 CCI-000382 Ubuntu 22.04 LTS must be configured to prohibit or restrict the use of functions, ports, protocols, and/or services, as defined in the PPSM CAL and vulnerability assessments.
UBTU-22-252010 CCI-001891 Ubuntu 22.04 LTS must, for networked systems, compare internal information system clocks at least every 24 hours with a server synchronized to one of the redundant United States Naval Observatory (USNO) time servers, or a time server designated for the appropriate DOD network (NIPRNet/SIPRNet), and/or the Global Positioning System (GPS).
UBTU-22-252015 CCI-002046 Ubuntu 22.04 LTS must synchronize internal information system clocks to the authoritative time source when the time difference is greater than one second.
UBTU-22-252020 CCI-001890 Ubuntu 22.04 LTS must record time stamps for audit records that can be mapped to Coordinated Universal Time (UTC).
UBTU-22-253010 CCI-001095 Ubuntu 22.04 LTS must be configured to use TCP syncookies.
UBTU-22-255010 CCI-002418 Ubuntu 22.04 LTS must have SSH installed.
UBTU-22-255015 CCI-002418 Ubuntu 22.04 LTS must use SSH to protect the confidentiality and integrity of transmitted information.
UBTU-22-255020 CCI-000048 Ubuntu 22.04 LTS must display the Standard Mandatory DOD Notice and Consent Banner before granting any local or remote connection to the system.
UBTU-22-255025 CCI-000366 Ubuntu 22.04 LTS must not allow unattended or automatic login via SSH.
UBTU-22-255030 CCI-000879 Ubuntu 22.04 LTS must be configured so that all network connections associated with SSH traffic terminate after becoming unresponsive.
UBTU-22-255035 CCI-001133 Ubuntu 22.04 LTS must be configured so that all network connections associated with SSH traffic are terminated after 10 minutes of becoming unresponsive.
UBTU-22-255040 CCI-000366 Ubuntu 22.04 LTS must be configured so that remote X connections are disabled, unless to fulfill documented and validated mission requirements.
UBTU-22-255045 CCI-000366 Ubuntu 22.04 LTS SSH daemon must prevent remote hosts from connecting to the proxy display.
UBTU-22-255050 CCI-000068 Ubuntu 22.04 LTS must configure the SSH daemon to use FIPSĀ 140-3-approved ciphers to prevent the unauthorized disclosure of information and/or detect changes to information during transmission.
UBTU-22-255055 CCI-001453 Ubuntu 22.04 LTS must configure the SSH daemon to use Message Authentication Codes (MACs) employing FIPS 140-3-approved cryptographic hashes to prevent the unauthorized disclosure of information and/or detect changes to information during transmission.
UBTU-22-255060 CCI-000068 Ubuntu 22.04 LTS SSH server must be configured to use only FIPS-validated key exchange algorithms.
UBTU-22-255065 CCI-000877 Ubuntu 22.04 LTS must use strong authenticators in establishing nonlocal maintenance and diagnostic sessions.
UBTU-22-271010 CCI-000048 Ubuntu 22.04 LTS must enable the graphical user logon banner to display the Standard Mandatory DOD Notice and Consent Banner before granting local access to the system via a graphical user logon.
UBTU-22-271015 CCI-000048 Ubuntu 22.04 LTS must display the Standard Mandatory DOD Notice and Consent Banner before granting local access to the system via a graphical user logon.
UBTU-22-271020 CCI-000056 Ubuntu 22.04 LTS must retain a user's session lock until that user reestablishes access using established identification and authentication procedures.
UBTU-22-271025 CCI-000057 Ubuntu 22.04 LTS must initiate a graphical session lock after 15 minutes of inactivity.
UBTU-22-271030 CCI-000366 Ubuntu 22.04 LTS must disable the x86 Ctrl-Alt-Delete key sequence if a graphical user interface is installed.
UBTU-22-291010 CCI-001958 Ubuntu 22.04 LTS must disable automatic mounting of Universal Serial Bus (USB) mass storage driver.
UBTU-22-291015 CCI-002418 Ubuntu 22.04 LTS must disable all wireless network adapters.
UBTU-22-411010 CCI-000770 Ubuntu 22.04 LTS must prevent direct login into the root account.
UBTU-22-411015 CCI-000764 Ubuntu 22.04 LTS must uniquely identify interactive users.
UBTU-22-411020 CCI-002041 Ubuntu 22.04 LTS must allow the use of a temporary password for system logons with an immediate change to a permanent password.
UBTU-22-411025 CCI-000198 Ubuntu 22.04 LTS must enforce 24 hours/1 day as the minimum password lifetime. Passwords for new users must have a 24 hours/1 day minimum password lifetime restriction.
UBTU-22-411030 CCI-000199 Ubuntu 22.04 LTS must enforce a 60-day maximum password lifetime restriction. Passwords for new users must have a 60-day maximum password lifetime restriction.
UBTU-22-411035 CCI-000795 Ubuntu 22.04 LTS must disable account identifiers (individuals, groups, roles, and devices) after 35 days of inactivity.
UBTU-22-411040 CCI-000016 Ubuntu 22.04 LTS must automatically expire temporary accounts within 72 hours.
UBTU-22-411045 CCI-000044 Ubuntu 22.04 LTS must automatically lock an account until the locked account is released by an administrator when three unsuccessful logon attempts have been made.
UBTU-22-412010 CCI-000366 Ubuntu 22.04 LTS must enforce a delay of at least four seconds between logon prompts following a failed logon attempt.
UBTU-22-412015 CCI-000366 Ubuntu 22.04 LTS must display the date and time of the last successful account logon upon logon.
UBTU-22-412020 CCI-000054 Ubuntu 22.04 LTS must limit the number of concurrent sessions to ten for all accounts and/or account types.
UBTU-22-412025 CCI-000058 Ubuntu 22.04 LTS must allow users to directly initiate a session lock for all connection types.
UBTU-22-412030 CCI-002361 Ubuntu 22.04 LTS must automatically exit interactive command shell user sessions after 15 minutes of inactivity.
UBTU-22-412035 CCI-000366 Ubuntu 22.04 LTS default filesystem permissions must be defined in such a way that all authenticated users can read and modify only their own files.
UBTU-22-431010 CCI-001764 Ubuntu 22.04 LTS must have the "apparmor" package installed.
UBTU-22-431015 CCI-001764 Ubuntu 22.04 LTS must be configured to use AppArmor.
UBTU-22-432010 CCI-002038 Ubuntu 22.04 LTS must require users to reauthenticate for privilege escalation or when changing roles.
UBTU-22-432015 CCI-001084 Ubuntu 22.04 LTS must ensure only users who need access to security functions are part of sudo group.
UBTU-22-611010 CCI-000192 Ubuntu 22.04 LTS must enforce password complexity by requiring at least one uppercase character be used.
UBTU-22-611015 CCI-000193 Ubuntu 22.04 LTS must enforce password complexity by requiring at least one lowercase character be used.
UBTU-22-611020 CCI-000194 Ubuntu 22.04 LTS must enforce password complexity by requiring that at least one numeric character be used.
UBTU-22-611025 CCI-001619 Ubuntu 22.04 LTS must enforce password complexity by requiring that at least one special character be used.
UBTU-22-611030 CCI-000366 Ubuntu 22.04 LTS must prevent the use of dictionary words for passwords.
UBTU-22-611035 CCI-000205 Ubuntu 22.04 LTS must enforce a minimum 15-character password length.
UBTU-22-611040 CCI-000195 Ubuntu 22.04 LTS must require the change of at least eight characters when passwords are changed.
UBTU-22-611045 CCI-000366 Ubuntu 22.04 LTS must be configured so that when passwords are changed or new passwords are established, pwquality must be used.
UBTU-22-611050 CCI-000200 Ubuntu 22.04 LTS must prohibit password reuse for a minimum of five generations.
UBTU-22-611055 CCI-000196 Ubuntu 22.04 LTS must store only encrypted representations of passwords.
UBTU-22-611060 CCI-000366 Ubuntu 22.04 LTS must not allow accounts configured with blank or null passwords.
UBTU-22-611065 CCI-000366 Ubuntu 22.04 LTS must not have accounts configured with blank or null passwords.
UBTU-22-611070 CCI-000803 Ubuntu 22.04 LTS must encrypt all stored passwords with a FIPS 140-3-approved cryptographic hashing algorithm.
UBTU-22-612010 CCI-000765 Ubuntu 22.04 LTS must implement multifactor authentication for remote access to privileged accounts in such a way that one of the factors is provided by a device separate from the system gaining access.
UBTU-22-612015 CCI-001953 Ubuntu 22.04 LTS must accept personal identity verification (PIV) credentials.
UBTU-22-612020 CCI-000765 Ubuntu 22.04 LTS must implement smart card logins for multifactor authentication for local and network access to privileged and nonprivileged accounts.
UBTU-22-612025 CCI-001954 Ubuntu 22.04 LTS must electronically verify personal identity verification (PIV) credentials.
UBTU-22-612030 CCI-000185 Ubuntu 22.04 LTS, for PKI-based authentication, must validate certificates by constructing a certification path (which includes status information) to an accepted trust anchor.
UBTU-22-612035 CCI-001991 Ubuntu 22.04 LTS for PKI-based authentication, must implement a local cache of revocation data in case of the inability to access revocation information via the network.
UBTU-22-612040 CCI-000187 Ubuntu 22.04 LTS must map the authenticated identity to the user or group account for PKI-based authentication.
UBTU-22-631010 CCI-002470 Ubuntu 22.04 LTS must use DOD PKI-established certificate authorities for verification of the establishment of protected sessions.
UBTU-22-631015 CCI-002007 Ubuntu 22.04 LTS must be configured such that Pluggable Authentication Module (PAM) prohibits the use of cached authentications after one day.
UBTU-22-651010 CCI-002696 Ubuntu 22.04 LTS must use a file integrity tool to verify correct operation of all security functions.
UBTU-22-651015 CCI-002696 Ubuntu 22.04 LTS must configure AIDE to perform file integrity checking on the file system.
UBTU-22-651020 CCI-001744 Ubuntu 22.04 LTS must notify designated personnel if baseline configurations are changed in an unauthorized manner. The file integrity tool must notify the system administrator when changes to the baseline configuration or anomalies in the operation of any security functions are discovered.
UBTU-22-651025 CCI-002699 Ubuntu 22.04 LTS must be configured so that the script that runs each 30 days or less to check file integrity is the default.
UBTU-22-651030 CCI-001496 Ubuntu 22.04 LTS must use cryptographic mechanisms to protect the integrity of audit tools.
UBTU-22-651035 CCI-001851 Ubuntu 22.04 LTS must have a crontab script running weekly to offload audit events of standalone systems.
UBTU-22-652010 CCI-001665 Ubuntu 22.04 LTS must be configured to preserve log records from failure events.
UBTU-22-652015 CCI-000067 Ubuntu 22.04 LTS must monitor remote access methods.
UBTU-22-653010 CCI-000130 Ubuntu 22.04 LTS must have the "auditd" package installed.
UBTU-22-653015 CCI-000130 Ubuntu 22.04 LTS must produce audit records and reports containing information to establish when, where, what type, the source, and the outcome for all DOD-defined auditable events and actions in near real time.
UBTU-22-653020 CCI-001851 Ubuntu 22.04 LTS audit event multiplexor must be configured to offload audit logs onto a different system from the system being audited.
UBTU-22-653025 CCI-000139 Ubuntu 22.04 LTS must alert the information system security officer (ISSO) and system administrator (SA) in the event of an audit processing failure.
UBTU-22-653030 CCI-000140 Ubuntu 22.04 LTS must shut down by default upon audit failure.
UBTU-22-653035 CCI-001849 Ubuntu 22.04 LTS must allocate audit record storage capacity to store at least one weeks' worth of audit records, when audit records are not immediately sent to a central audit record storage facility.
UBTU-22-653040 CCI-001855 Ubuntu 22.04 LTS must immediately notify the system administrator (SA) and information system security officer (ISSO) when the audit record storage volume reaches 25 percent remaining of the allocated capacity.
UBTU-22-653045 CCI-000162 Ubuntu 22.04 LTS must be configured so that audit log files are not read- or write-accessible by unauthorized users.
UBTU-22-653050 CCI-000162 Ubuntu 22.04 LTS must be configured to permit only authorized users ownership of the audit log files.
UBTU-22-653055 CCI-000162 Ubuntu 22.04 LTS must permit only authorized groups ownership of the audit log files.
UBTU-22-653060 CCI-000164 Ubuntu 22.04 LTS must be configured so that the audit log directory is not write-accessible by unauthorized users.
UBTU-22-653065 CCI-000171 Ubuntu 22.04 LTS must be configured so that audit configuration files are not write-accessible by unauthorized users.
UBTU-22-653070 CCI-000171 Ubuntu 22.04 LTS must permit only authorized accounts to own the audit configuration files.
UBTU-22-653075 CCI-000171 Ubuntu 22.04 LTS must permit only authorized groups to own the audit configuration files.
UBTU-22-654010 CCI-000172 Ubuntu 22.04 LTS must generate audit records for successful/unsuccessful uses of the apparmor_parser command.
UBTU-22-654015 CCI-000172 Ubuntu 22.04 LTS must generate audit records for successful/unsuccessful uses of the chacl command.
UBTU-22-654020 CCI-000172 Ubuntu 22.04 LTS must generate audit records for successful/unsuccessful uses of the chage command.
UBTU-22-654025 CCI-000172 Ubuntu 22.04 LTS must generate audit records for successful/unsuccessful uses of the chcon command.
UBTU-22-654030 CCI-000172 Ubuntu 22.04 LTS must generate audit records for successful/unsuccessful uses of the chfn command.
UBTU-22-654035 CCI-000172 Ubuntu 22.04 LTS must generate audit records for successful/unsuccessful uses of the chsh command.
UBTU-22-654040 CCI-000172 Ubuntu 22.04 LTS must generate audit records for successful/unsuccessful uses of the crontab command.
UBTU-22-654045 CCI-000172 Ubuntu 22.04 LTS must generate audit records for successful/unsuccessful attempts to use the fdisk command.
UBTU-22-654050 CCI-000172 Ubuntu 22.04 LTS must generate audit records for successful/unsuccessful uses of the gpasswd command.
UBTU-22-654055 CCI-000172 Ubuntu 22.04 LTS must generate audit records for successful/unsuccessful attempts to use the kmod command.
UBTU-22-654060 CCI-000172 Ubuntu 22.04 LTS must generate audit records for successful/unsuccessful attempts to use modprobe command.
UBTU-22-654065 CCI-000172 Ubuntu 22.04 LTS must generate audit records for successful/unsuccessful uses of the mount command.
UBTU-22-654070 CCI-000172 Ubuntu 22.04 LTS must generate audit records for successful/unsuccessful uses of the newgrp command.
UBTU-22-654075 CCI-000172 Ubuntu 22.04 LTS must generate audit records for successful/unsuccessful uses of the pam_timestamp_check command.
UBTU-22-654080 CCI-000172 Ubuntu 22.04 LTS must generate audit records for successful/unsuccessful uses of the passwd command.
UBTU-22-654085 CCI-000172 Ubuntu 22.04 LTS must generate audit records for successful/unsuccessful uses of the setfacl command.
UBTU-22-654090 CCI-000172 Ubuntu 22.04 LTS must generate audit records for successful/unsuccessful uses of the ssh-agent command.
UBTU-22-654095 CCI-000172 Ubuntu 22.04 LTS must generate audit records for successful/unsuccessful uses of the ssh-keysign command.
UBTU-22-654100 CCI-000172 Ubuntu 22.04 LTS must generate audit records for successful/unsuccessful uses of the su command.
UBTU-22-654105 CCI-000172 Ubuntu 22.04 LTS must generate audit records for successful/unsuccessful uses of the sudo command.
UBTU-22-654110 CCI-000172 Ubuntu 22.04 LTS must generate audit records for successful/unsuccessful uses of the sudoedit command.
UBTU-22-654115 CCI-000172 Ubuntu 22.04 LTS must generate audit records for successful/unsuccessful uses of the umount command.
UBTU-22-654120 CCI-000172 Ubuntu 22.04 LTS must generate audit records for successful/unsuccessful uses of the unix_update command.
UBTU-22-654125 CCI-000172 Ubuntu 22.04 LTS must generate audit records for successful/unsuccessful uses of the usermod command.
UBTU-22-654130 CCI-000018 Ubuntu 22.04 LTS must generate audit records for all account creations, modifications, disabling, and termination events that affect /etc/group.
UBTU-22-654135 CCI-000018 Ubuntu 22.04 LTS must generate audit records for all account creations, modifications, disabling, and termination events that affect /etc/gshadow.
UBTU-22-654140 CCI-000018 Ubuntu 22.04 LTS must generate audit records for all account creations, modifications, disabling, and termination events that affect /etc/opasswd.
UBTU-22-654145 CCI-000018 Ubuntu 22.04 LTS must generate audit records for all account creations, modifications, disabling, and termination events that affect /etc/passwd.
UBTU-22-654150 CCI-000018 Ubuntu 22.04 LTS must generate audit records for all account creations, modifications, disabling, and termination events that affect /etc/shadow.
UBTU-22-654155 CCI-000172 Ubuntu 22.04 LTS must generate audit records for successful/unsuccessful uses of the chmod, fchmod, and fchmodat system calls.
UBTU-22-654160 CCI-000172 Ubuntu 22.04 LTS must generate audit records for successful/unsuccessful uses of the chown, fchown, fchownat, and lchown system calls.
UBTU-22-654165 CCI-000172 Ubuntu 22.04 LTS must generate audit records for successful/unsuccessful uses of the creat, open, openat, open_by_handle_at, truncate, and ftruncate system calls.
UBTU-22-654170 CCI-000172 Ubuntu 22.04 LTS must generate audit records for successful/unsuccessful uses of the delete_module system call.
UBTU-22-654175 CCI-000172 Ubuntu 22.04 LTS must generate audit records for successful/unsuccessful uses of the init_module and finit_module system calls.
UBTU-22-654180 CCI-000172 Ubuntu 22.04 LTS must generate audit records for any use of the setxattr, fsetxattr, lsetxattr, removexattr, fremovexattr, and lremovexattr system calls.
UBTU-22-654185 CCI-000172 Ubuntu 22.04 LTS must generate audit records for any successful/unsuccessful use of unlink, unlinkat, rename, renameat, and rmdir system calls.
UBTU-22-654190 CCI-000366 Ubuntu 22.04 LTS must generate audit records for all events that affect the systemd journal files.
UBTU-22-654195 CCI-000172 Ubuntu 22.04 LTS must generate audit records for the /var/log/btmp file.
UBTU-22-654200 CCI-000172 Ubuntu 22.04 LTS must generate audit records for the /var/log/wtmp file.
UBTU-22-654205 CCI-000172 Ubuntu 22.04 LTS must generate audit records for the /var/run/utmp file.
UBTU-22-654210 CCI-000172 Ubuntu 22.04 LTS must generate audit records for the use and modification of faillog file.
UBTU-22-654215 CCI-000172 Ubuntu 22.04 LTS must generate audit records for the use and modification of the lastlog file.
UBTU-22-654220 CCI-000172 Ubuntu 22.04 LTS must generate audit records when successful/unsuccessful attempts to modify the /etc/sudoers file occur.
UBTU-22-654225 CCI-000172 Ubuntu 22.04 LTS must generate audit records when successful/unsuccessful attempts to modify the /etc/sudoers.d directory occur.
UBTU-22-654230 CCI-002233 Ubuntu 22.04 LTS must prevent all software from executing at higher privilege levels than users executing the software and the audit system must be configured to audit the execution of privileged functions.
UBTU-22-654235 CCI-000172 Ubuntu 22.04 LTS must generate audit records for privileged activities, nonlocal maintenance, diagnostic sessions and other system-level access.
UBTU-22-671010 CCI-002450 Ubuntu 22.04 LTS must implement NIST FIPS-validated cryptography to protect classified information and for the following: To provision digital signatures, to generate cryptographic hashes, and to protect unclassified information requiring confidentiality and cryptographic protection in accordance with applicable federal laws, Executive Orders, directives, policies, regulations, and standards.